ダッシュボード
ダッシュボードの大文字と小文字を区別しないインスタンスプロパティフィルタリング
ダッシュボードのインスタンスプロパティのフィルタリングロジックで、大文字と小文字が区別されなくなりました。「ABC」、「abc」、「Abc」などの値は同等とみなされるため、フィルタードロップダウンでの重複エントリが防止され、フィルタリング動作の一貫性が確保されます。
この機能改善にアクセスするには、ダッシュボードに移動してフィルターを作成します。
詳細については、を参照してください。 最新のダッシュボード 製品ドキュメントに記載されています。
ダッシュボードで請求ウィジェットが利用可能になりました
LogicMonitor ダッシュボードで課金ウィジェットを作成し、クラウド コスト情報を視覚化できるようになりました。
このウィジェットは、請求データを一目で確認できる複数のカスタマイズビューを提供します。また、ウィジェット内でより詳細な請求データにドリルダウンすることで、クラウド支出の可視性を高めることができます。
請求ウィジェットを作成するには、 ダッシュボード 追加を選択 ウィジェット > 請求.
請求ウィジェットを作成するには、コスト最適化製品へのアクセスが必要です。
詳細については、を参照してください。 請求ウィジェット 製品ドキュメントに記載されています。
読み取り専用 API ユーザーが誤ってウィジェット共有リンクを作成および削除できる問題を修正しました。
適切な権限を持たない API ユーザーが権限チェックをバイパスしてダッシュボードを削除できる問題を修正しました。
インテグレーション
完全なServiceNowドメイン構成のサポート
LogicMonitor を、完全なカスタムドメイン URL を使用して ServiceNow インスタンスに接続するように設定できるようになりました。これにより、非標準ドメインやリージョン固有のドメインでホストされているインスタンスをサポートできるようになり、さまざまな ServiceNow 環境との互換性が向上します。
以前は、 サブドメイン フィールドが利用可能になり、ユーザーはServiceNowインスタンスのサブドメインプレフィックスのみを指定する必要がありました(例: devの の dev.service-now.com)。この新しいオプションを使用すると、新しい カスタムドメインURLを使用する スイッチ。
詳細については、を参照してください。 ServiceNow(インシデント管理)統合 製品ドキュメントに記載されています。
モジュール
強化されたスクリプト NetScans が Groovy 4 に対応
さまざまなプラットフォーム向けの次の拡張スクリプト ネットスキャンは、Groovy 4 と互換性があります。詳細については、製品ドキュメントを参照してください。
強化された lm.data.topo スニペット
強化された lm.data.topo スニペットはKubernetes Linux Calico MACアドレスをブロックするようになりました。これにより、一意でないCalico MACアドレスがトポロジデータを汚染するのを防ぎ、ネットワークトポロジマップの精度が向上します。
強化された VMware vSphere NetScan
機能強化されたVMware vSphere NetScanでは、リソースツリー内の関連ルートフォルダ内にリソースが配置されるようになりました。この機能強化により、リソースの整理が改善されます。
詳細については、を参照してください。 VMware vSphereの監視 製品ドキュメントに記載されています。
強化された cisco.ucs スニペット
その cisco.ucs スニペットはパスワード内の特殊文字を正しくエスケープするようになりました。この機能強化により、信頼性の高い認証が確保され、エスケープされていない文字によるスクリプト実行の失敗を防ぐことができます。
Apache Groovy 4 によるすべての LogicMonitor 提供の LogicModule のサポート
将来のリリースでは、LogicMonitor コレクターは Apache Groovy 2 をサポートしなくなります。LogicMonitor が提供するすべての公式モジュールは、Apache Groovy 4 と互換性を持つようになります。この移行をサポートするために、LogicMonitor は、Groovy 4 と互換性を持つ公式 LogicModules のアップデートをリリースする予定です。
この移行の結果、次のことを行う必要があります。
- カスタマイズされたモジュールまたはコミュニティが提供するモジュールを検証して互換性を確保します
カスタマイズしたモジュールの検証の詳細については、次を参照してください。 カスタム モジュール Groovy 移行の検証 製品ドキュメントに記載されています。 - 互換性の変更がリリースされた LogicMonitor 提供のモジュールのモジュール更新をインストールします。
詳細については、を参照してください。 LogicMonitor 提供モジュール Groovy 4 移行 製品ドキュメントに記載されています。 - 拡張スクリプト NetScans を Groovy 4 互換スクリプトに更新します。
詳細については、リリース ノートのモジュール セクションの「Enhanced Script NetScans Now Groovy 4 compatible」を参照してください。
この移行のタイムラインの詳細については、以下を参照してください。 Apache Groovy 2 のサポート終了マイルストーンの公開発表.
LogicMonitor EA Collector 34.500 以降は、Groovy 2 および Groovy 4 と互換性があります。EA Collector リリースの詳細については、「 EAコレクター34.500 リリースノート。
現在利用可能な LogicMonitor EA Collector 37.100 では、Groovy 4 ではなく Groovy 2 が使用されます。Collector のバージョン管理に従って、安定した EA バージョンはオプションの一般リリース (GD) として指定されます。
注意: 今後のリリースで利用可能になる LogicMonitor GD Collector では、Groovy 4 ではなく Groovy 2 が使用されます。Collector のバージョン管理に従って、安定した GD バージョンはオプションの一般リリース (MGD) として指定されます。
Apache Groovy 4 を使用してモジュールを実行し、groovy.json.JsonSlurper() を使用すると、LogicMonitor Collector バージョン 36.200 以降で次の例外が修正されました。
exception:groovy.lang.RunTimeException: Unable to load FastStringService
注意: Apache Groovy 4 を使用してモジュールを実行するときにこの問題を軽減するには、LogicMonitor Collector バージョン 36.200 以降にアップグレードしてください。
Apache Groovy 4 を使用してモジュールを実行し、java.util.Date.format() を使用すると、LogicMonitor Collector バージョン 35.400 以降で次の例外が解決されました。
exception:groovy.lang.MissingMethodException: No signature of method: java.util.Date.format() is applicable for argument types: (String) values: [yyyy-MM-dd'T'HH:mm:ss z]
注意: Apache Groovy 4 を使用してモジュールを実行するときにこの問題を軽減するには、LogicMonitor Collector バージョン 35.400 以降にアップグレードしてください。
スクリプト内のレガシー クラスで Apache Groovy 4 を使用してモジュールを実行すると、次の例外がスローされる可能性があります。
java.lang.RuntimeException: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed
この問題を軽減するには、JPMS 準拠のパッケージ名に移行します。この変更を行っても、Groovy 2 との下位互換性は失われません。
たとえば、次のスクリプトはレガシー クラスを使用します。
import groovy.util.XmlSlurper
import groovy.util.XmlParser
def xmlSlurper = new XmlSlurper()
def xmlParser = new XmlParser()
Groovy 4 では、従来のクラスを JPMS 準拠のパッケージ名に置き換えて、次のように例外を解決できます。
import groovy.xml.XmlSlurper
import groovy.xml.XmlParser
def xmlSlurper = new XmlSlurper()
def xmlParser = new XmlParser()
重要: LogicMonitor は、LogicMonitor が提供するモジュールのこの問題を軽減するために、公式 LogicModules の更新プログラムをリリースしています。
スクリプト内のレガシー クラスで Apache Groovy 4 を使用してモジュールを実行すると、次の例外がスローされる可能性があります。
java.lang.RuntimeException: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed
この問題を軽減するには、JPMS 準拠のパッケージ名に移行します。この変更を行っても、Groovy 2 との下位互換性は失われません。
たとえば、次のスクリプトはレガシー クラスを使用します。
import groovy.util.XmlSlurper
import groovy.util.XmlParser
def xmlSlurper = new XmlSlurper()
def xmlParser = new XmlParser()
Groovy 4 では、従来のクラスを JPMS 準拠のパッケージ名に置き換えて、次のように例外を解決できます。
import groovy.xml.XmlSlurper
import groovy.xml.XmlParser
def xmlSlurper = new XmlSlurper()
def xmlParser = new XmlParser()
重要: LogicMonitor は、LogicMonitor が提供する公式モジュールのこの問題を軽減するために、LogicModules の更新プログラムをリリースしています。
Apache Groovy 4 では、List クラスの push() メソッドの動作が逆になっています。Apache Groovy 2.4 では、push() メソッドはリストに項目を追加しますが、Apache Groovy 4 では push() はリストの最初の項目に対して機能します。
// v4 Behavior
def numbers = [1, 2, 3, 4]
numbers.push(5)
println numbers
// OUTPUT: [5, 1, 2, 3, 4]
// v2.4 Behavior
def numbers = [1, 2, 3, 4]
numbers.push(5)
println numbers
// OUTPUT: [1, 2, 3, 4, 5]
この問題を軽減するには、push() の代わりに add() を使用するように移行します。
def numbers = [1, 2, 3, 4]
numbers.add("5")
println numbers
// OUTPUT: [1, 2, 3, 4, 5]
Apache Groovy 4 を使用してモジュールを実行すると、pop() メソッドの動作が逆になります。Apache Groovy 2.4 では、pop() の動作によりリストの最後の項目が削除されますが、Groovy 4 では、pop() によりリストの最初の項目が削除されます。
// v4 Behavior
def numbers = [1, 2, 3, 4]
println numbers.pop()
// OUTPUT: 1
// v2.4 Behavior
def numbers = [1, 2, 3, 4]
println numbers.pop()
// OUTPUT: 4
この問題を軽減するには、pop() の代わりに remove() を使用するように移行します。
def numbers = [1, 2, 3, 4]
println numbers.remove(numbers.size() - 1)
// OUTPUT: 4
重要: LogicMonitor は、LogicMonitor が提供する公式モジュールのこの問題を軽減するために、LogicModules の更新プログラムをリリースしています。
Apache Groovy 4 を使用してモジュールを実行する場合、GroovyScriptHelper を使用して LogicMonitor スニペットをスクリプトに組み込むと、次の例外がスローされる可能性があります。
exception:groovy.lang.MissingPropertyException: No such property
この問題を軽減するには、次のようにクラスのインポート方法を調整します。
import com.santaba.agent.groovy.utils.GroovyScriptHelper
import com.logicmonitor.mod.Snippets
def modLoader = GroovyScriptHelper.getInstance(GroovySystem.version).getScript("Snippets", Snippets.getLoader()).withBinding(getBinding())
重要:LogicMonitor は、LogicMonitor が提供するモジュールのこの問題を軽減するために、公式 LogicModules の更新プログラムをリリースしています。
Apache Groovy 4 を使用してモジュールを実行するときに、モジュールにデータ構造の無効な型パラメータが含まれていると、モジュールは次の例外をスローします。
java.lang.RuntimeException: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
重要: LogicMonitor は、LogicMonitor が提供する公式モジュールのこの問題を軽減するために、LogicModules の更新プログラムをリリースしています。
レポート
読み取り専用 API ユーザーがレポートを削除できる問題を修正しました。
最大リクエストしきい値を含む CSV 形式のアラート レポートを作成すると失敗し、ログに次のエラーが記録されます。 java.lang.OutOfMemoryError
資料
AIおよびLLM製品サポートオンボーディングが利用可能になりました
様々な人工知能(AI)および大規模言語モデル(LLM)製品の監視を、単一のオンボーディングページから設定できるようになりました。このページでは、LogicMonitorがサポートするすべてのAIおよびLLM製品を確認し、必要なサービスの監視をすぐに開始できます。
MFAデバイスに移動する リソースツリー LogicMonitorで選択 追加 > AIと法学修士 オンボーディング ページにアクセスします。
注意: 一部のAIおよびLLMモジュールでは追加の設定が必要です。これらの製品の下にある「追加」を選択して、監視を直接設定してください。
LogicModules が自動的に有効になる製品の詳細については、「詳細を見る」を選択してください。
形跡
LogicMonitor OpenTelemetry Collector 3.0.00 の廃止
LogicMonitor の今後のリリースでは、LogicMonitor OpenTelemetry Collector 3.0.00 のサポートが廃止される予定です。最新バージョンの LogicMonitor OpenTelemetry Collector をご利用ください。
詳細については、を参照してください。 OpenTelemetry コレクターのバージョン 製品ドキュメントに記載されています。
ロジックモジュールのリリース
新規および更新された LogicModule は、LogicMonitor ポータルで直接利用できます。 Exchange から新しいモジュールをインストールしたり、My Module Toolbox で既存のモジュールを更新したりできます。詳細については、「」を参照してください。 モジュールのインストール, モジュール管理 製品ドキュメントに記載されています。
このセクションでは、このリリースで新しく追加された、このリリースで更新された、または将来のリリースで削除される LogicModule を一覧表示します。LogicModule 機能に関連する変更は、「一般的な更新」セクションに一覧表示されます。
新しいLogicModules
| LogicModule名 | Details |
| 2 つのデータソース: – Cisco_IOSXE_CPU_コア – Cisco_IOSXE_プロセス 1 つのプロパティソース: – 追加カテゴリ_Cisco_IOSXE | Cisco IOS XE の監視を追加します。CPU コアとプロセス レベルのメトリックを追跡します。 |
| 1 ログソース: – Windowsイベントログ | アプリケーション、システム、セキュリティの各チャネルからWindowsイベントログを取り込み、セキュリティ監査成功イベントを除外することで、ノイズを削減し、運用上のベストプラクティスに準拠します。 |
| 1 データソース: – SaaS_StatusSalesforce_Status | Tableau と Mulesoft をサポートするようになりました。 |
| 1 データソース: – NetApp_ONTAP_PolicyGroups1 データソース: – NetApp_ONTAP_iSCSI1 データソース: – NetApp_ONTAP_Quotas1 データソース: – NetApp_ONTAP_SnapMirror1 データソース: – NetApp_ONTAP_ファイバーチャネル | ONTAP REST APIを使用してNetApp FASおよびAFFシステムを監視します。ONTAPI/ZAPIから移行するONTAP 9.1x環境を対象としています。 |
| 1 データソース: – AWS_アプリケーション移行サービス_サービスメトリクス | AWS Application Migration Service の監視を追加します。CloudWatch を使用してソースサーバーの数を収集します。 |
| 1 データソース: – AWS_アプリケーション移行サービス | AWS Application Migration Service の監視機能を追加します。CloudWatch を使用して、Certificate Manager 証明書のメトリクスを収集します。AWS の規定により、最小ポーリング間隔は 1 日です。 |
更新されたLogicModules
| LogicModule名 | Details |
| 1 データソース: – Cisco_Catalyst_AccessPointPerformance | 問題を修正しました。 ClientCount バージョン 0 以降を実行している Catalyst Center では、データポイントは常に 2.3.7.6 を報告しました。 |
| 4 つのデータソース: – Cisco_Catalyst_AccessPointHealth – Cisco_Catalyst_RouterHealth – Cisco_Catalyst_SwitchHealth – Cisco_Catalyst_WLCHealth | データなしアラートを削除しました。 |
| 12 つのデータソース: – Veeam_バックアップとレプリケーション_バックアップセッション – Veeam_バックアップおよびレプリケーション_HyperVプロキシサーバー – Veeam_バックアップとレプリケーション_ジョブ_バックアップ – Veeam_BackupAndReplication_Jobs_Configバックアップ – Veeam_バックアップとレプリケーション_ジョブ_コピー – Veeam_BackupAndReplication_Jobs_ManagedAgentBackups – Veeam_BackupAndReplication_Jobs_SureBackups – Veeam_バックアップとレプリケーション_ジョブ_同期 – Veeam_バックアップおよびレプリケーション_ジョブ_Windowsエージェント – Veeam_バックアップとレプリケーション_リポジトリ – Veeam_BackupAndReplication_ScaleOutリポジトリ – Veeam_バックアップおよびレプリケーション_VMwareプロキシサーバー | Azure プロパティが存在しない場合に一部のデバイスでインスタンスの検出が妨げられる問題を解決しました。 |
| 1 データソース: – Cato_SDWAN_トンネル | トンネルが不足していたために発生した障害を解決しました tunnelRemoteIPInfo API レスポンスで。 |
| 2 つのデータソース: – Cisco_トランシーバー_センサーCLI – Puppet_Agent_LastRunMetrics 1 プロパティソース: – ConfigCheck_4_Interactive 3 構成ソース: – Citrix_Netscaler_FullBackup_SFTP – SSH_Interactive_Dynamic – SSH_Interactive_Standard | 問題を解決しました。 ssh.publickey.pass プロパティは利用できませんでした。 |
| 1 つのプロパティソース: – カテゴリーを追加_EMCUnity | Unity VSA モデルの検出をサポートするために正規表現を更新しました。 |
| 1 データソース: – HP_システム_物理ドライブ | 更新中 ssdWearStatus データポイントロジック。ディスクの使用量が残り5%になるとアラートを発し、交換が必要な場合は重要なアラートを送信することで、以前の早すぎるアラートに対処できるようになりました。 |
| 1 データソース: – Cisco_Meraki_CellularGatewayHealth | 解析スニペットのインポートを追加しました。 |
| 1 データソース: – Microsoft_Azure_リソースヘルス | アラートの改善 AvailabilityStateErrorAlerts不明な状態(2)のアラートを削除しました。 UnknownAvailabilityStateErrorAlerts 2 回のポーリング後に警告アラートが表示されたデータポイント。 |
| 1 つのプロパティソース: – Linux_SSH_情報 | 行方不明の処理 cpu cores フィールドイン /proc/cpuinfo スクリプトのクラッシュを防ぐためです。 |
| 1 データソース: – Microsoft_SQLServer_GlobalPerformance | 以前の変更を元に戻し、 deadlocks/sec データポイントは合計デッドロックを反映します。 |
| 1 データソース: – Microsoft_Windows_Cluster_Disks | アラートの説明の誤字を修正しました。 #HOSTNAME# 正しく表示されるようになりました ##HOSTNAME##. |
| 1 つのプロパティソース: – Juniper_VirtualChassis_Info | Juniper MX80-Tデバイスからシリアル番号を取得するためのサポートを追加しました。 Device_Basic_Info PropertySource が失敗します。 |
| 2 つのデータソース: – Cisco_トランシーバー_センサーCLI – Puppet_Agent_LastRunMetrics 1 つのプロパティソース: – ConfigCheck_4_Interactive 3 構成ソース: – Citrix_Netscaler_FullBackup_SFTP – SSH_Interactive_Dynamic – SSH_Interactive_Standard | パスフレーズで保護されたSSHキーのサポートを追加しました ssh.cert.pass or ssh.publickey.pass. |
| 1 つのプロパティソース: – デバイス基本情報 | スクリプトのクラッシュを防ぐために、解決された IP の null セーフ チェックを追加しました。 |
| 1 つのプロパティソース: – Config_Fortinet_Generic | 共通設定に FortiADC のサポートが追加されました。 |
| 1 データソース: – Fortinet_FortiManager_デバイス | 正しくレポートするために、収集方法をSNMPからBATCHSCRIPTに更新しました。 policyPackageState. |
| 1 つのプロパティソース: – Config_Cisco_Generic | Cisco ASAデバイスの共通設定における重複インスタンスを削除しました。実行コンフィギュレーションと設定の表示は、テスト済みのバージョン間で同一の結果を返します。 |
| 1 構成ソース: – VMware_vSphere_VM 構成 | 使用できるように更新されました lm.remote SFTP 経由でファイルの内容を取得するためのスニペット。 |
| 2 つのデータソース: – NetApp_ONTAP_インターフェース – NetApp_ONTAP_Raid | キャッシュ スニペットの読み込みを妨げる問題を解決しました。 |
| 1 データソース: – Cisco_Meraki_API | HTTP 404 エラーの処理が強化されました。 |
| 1 ログソース: – Meraki ネットワーク イベント | auto.meraki.productType および meraki.productType に影響するタイプミスを修正しました。 |
| 1 つのデータソース: – VMware_SDWAN_BGP_Sessions | 強化された WildValue の粒度により、より多くのインスタンスを検出できるようになります。 注意: この変更の結果、すべてのインスタンスが置き換えられ、履歴データが失われます。 |


